domenica 24 agosto 2014

Canon AE-1 shutter repair

My Canon AE-1 suddenly did not expose at all: all shutter times "sounded" the same: a check showed the shutter was not opening at all, even "B".

There are several forum posts on the internet which report "magnet" problems usually related to random malfunction or to the camera firing while loading and they show you how to clean an electro-magnet.

My problem was different, but I decided to take a closer look.

The Canon AE-1 has two electro-magnets, one for the first curtain and on e for the second curtain.
If the first curtain is not correctly retained, the camera will fire too early or other problems I can only imagine. If the second curtain is not retained, there is no time delay and the camera makes the shortest possible time. It is not even 1/1000", in my case it was black, the second curtain catches up the first and the shutter is dark. It is the bigger magnet, protected by a plastic case.

Cleaning the second-curtain electro-magnet is easy; nothing to open, just gently sweep it off with alcohol without damaging the wires and solders. This magnet has no protection at all and evidently can get dirty easier.

Once cleaned, by trusty canon worked flawlessly again!

It is worth checking that the coils are still fine. In my case the first curtain electro-magnet had an in-circuit resistance of about 100 Ohm. The second curtain magnet has an in-circuit resistance of about 200 Ohm instead.

First curtain magnet

Second curtain magnet

Nessun commento:

Posta un commento